Introducing the cleanest Mozilla Links yet

Time for another Mozilla Links refresh. This time it’s gone minimal, with a grand total weight just below 25K for the home page by keeping all post images out of it and basically the same plus images for posts. So, hopefully, you should get faster performance overall.

Very soft colors all around following the UltraLight WordPress theme I am using. AdSense is using the exact same palette where possible.

Now: featuring the UltraLight WordPress theme.

Mozilla Links featuring the UltraLight WordPress theme

Before, with the BlackSplat WordPress theme:

Mozilla Links featuring the BlackSplat WordPress theme

Hope you enjoy the once again radical changes, and please let me know in the comments what’s broken, what you like, hate, miss, or wish. Thanks for reading Mozilla Links.

[poll id=”25″]

13 thoughts on “Introducing the cleanest Mozilla Links yet”

  1. … and bigger font. Actually, the font size is 14px which is okay with Arial. 14px Calibri feels like 12px Arial, only slightly bigger.

  2. I don’t think that the font should be black, but it should be a slightly darker shade of gray, and it should be MUCH darker here in the comment box, I can hardly see what I’m typing.

  3. Yeah, the font is my only complaint. Please, change it to something easy on the eyes. Otherwise, the new look is nice.

  4. These faded colours make the site look temporary. Stick with the high contrast colours will help people with vision issues.

  5. Thanks all for your comments. I’ve updated the font size to make it relative and not pixel defined as it was. Text is also closer to black (#444). Please keep the feedback coming!

  6. Nice work. Pages load nearly as fast as about:blank. 🙂
    We should all be as disciplined and selfless as you to put usability for our visitors first.

  7. Thanks for tweaking the font, Percy.

    I just noticed that the search is not working (for me, at least), and there doesn’t seem to be an easy way to page through older posts.

    1. Hi Matt, just tried the search and it is working right for me. I noticed there is a problem with the posts titles that I fixed a few days ago and Google may take a while to pcick up the changes.

      I was also pinged about the paging links and they are corrected now. Please let me know if you see any other bug. Thanks!

Comments are closed.