Firefox 3.5.6 patches several security bugs

Mozilla has released a new Firefox update, 3.5.6 which addresses seven security vulnerabilities, three of them labeled as critical,so users are encouraged to update as soon as possible.

Among the vulnerabilities, I find MFSA-69 an interesting one, as it could lead a user into believing he is in a secure web page (https://) due to an error on how certain server responses are handled.

To update, select Check for Updates… in the Help menu or just accept it when prompted within the next couple of days. Linux users using distro packages will have to wait for the update to be released to their respective repositories.

http://www.mozilla.org/securit/announce/2009/mfsa2009-69.html

One thought on “Firefox 3.5.6 patches several security bugs”

Comments are closed.